Sales: 03300 885 250
Support
Login

Easy WP SMTP WordPress Plugin Vulnerability

The very popular WordPress plugin Easy WP SMTP, has just patched a vulnerability that allows an attacker to take control of your website. The insecure flaw in the WordPress plugin allows hackers to be able to change the admin password and take complete control of a website.

Secure Cloud Server Hosting Illustration

Update Plugin Immediately

Updating the plugin immediately is very import and can easily be done through the WordPress dashboard.

The latest version of the plugin you need is 1.4.3 or above.

View plugin


Clook Internet is a trading style of Sub 6 Limited. Registered in England and Wales Registration No 4439133 | VAT Registration No 844 7894 73